Wednesday, October 13, 2010

Getting old

After breakfast this morning I went up to the shack as usual. I switched on the computer, switched on the main power supply and switched on the Kenwood TM-D710. When Windows came up I started my VHF instance of APRSIS32 for my local APRS gateway. Then I switched on my K2 to start the HF gateway. The LCD showed the usual "Elecraft" but then the segments went crazy and the radio emitted a noise that can best be described as an endless fart.


I switched off. Then I realized that I had forgotten to switch on the K2's power supply. I switched it on, then I switched the radio on again and this time it started up normally. Phew! Then my fuddled brain worked out that this must mean the K2's internal SLA battery has finally given up the ghost.

I built my K2 in 1999. Originally only the basic radio was available as a CW-only kit. Other options were soon added including the KSB2 module for SSB, the internal ATU and an internal battery pack. I added these options as soon as they were available, which must have been around the end of 1999 or early 2000, so the battery must be around ten years old.

As it happened I have rarely used my K2 portable so I have made little use of the battery pack. I used the radio in the field once earlier this year. The previous occasion on which I ran the K2 from the battery was during the floods a year ago when the power went off for several hours and I was able to experience what the bands were like without all the local QRN. Ten years is a very good life for an SLA battery and I wondered when it would fail, but I hated to throw it out while it was still doing its job. It seems that time had finally come.

I removed the top cover from the K2, disconnected the cables and lifted it off. Then I undid the screws securing the aluminium bracket that holds the battery in place. I noticed a small patch of corrosion in the area adjacent to one of the terminals, and when I removed the battery I noticed a drop of liquid in the same place. The battery had started to leak. I had got to it just in time. If my fuzzy-headedness hadn't caused me to turn on the K2 without the power supply I might never have noticed the problem until it was too late and some of this electrolyte had dripped into the radio itself!

I'm not sure whether to replace the battery pack or not. In the meantime I thought I would put the battery bracket back and tape the battery cables to it, then put the top back on the K2 and get my HF gateway back on the air.

But it isn't just the K2 that is getting old. I am, too, and I hate it. I've never had particularly good co-ordination but it seems to be getting worse. I can't use a Morse paddle now and I can't send faster than 12wpm with a straight key. Sometimes I have days where I'm even more clumsy than usual and my hands shake too much to do any constructional work. In that state it's impossible to hold nuts and washers in hard to access positions while you turn a screw from the other side. I'm having one of those days today and I found that I couldn't put the battery cover back. So I've put the K2 in a drawer until a day when I'm feeling sharper. Hopefully I'll be able to give it a realignment at the same time, something else it probably needs after ten years. Until that time I will be off the air on HF APRS.
Post a Comment